Unable to remove Java 8 after upgrade to java 11

After install java 11 we expect to remove java 8 but is not possible without removing candlepin and katello.

candlepin requires tomcatjss
tomcatjss requires jss
jss requires java-1.8.0-openjdk-headless (mo matter if java-11-openjdk-headless is present)

Expected outcome:
remove older java versions after update to java 11

Foreman and Proxy versions:
Foreman Version 2.5.2
Foreman Proxy: None

Foreman and Proxy plugin versions:

Distribution and version:
System: Redhat 7.9

Other relevant data:

Tomcatjss, candleping and katello being removed when I try to remove the old java version

# yum remove java-1.8.0-openjdk-headless
Loaded plugins: product-id, search-disabled-repos, subscription-manager, versionlock
Resolving Dependencies
--> Running transaction check
---> Package java-1.8.0-openjdk-headless.x86_64 1: will be erased
--> Processing Dependency: java-1.8.0-openjdk-headless for package: jss-4.4.9-3.el7.x86_64
--> Running transaction check
---> Package jss.x86_64 0:4.4.9-3.el7 will be erased
--> Processing Dependency: jss >= 4.4.7-1 for package: tomcatjss-7.2.5-1.el7.noarch
--> Running transaction check
---> Package tomcatjss.noarch 0:7.2.5-1.el7 will be erased
--> Processing Dependency: tomcatjss >= 7.2.1-7.1 for package: candlepin-4.0.6-1.el7.noarch
--> Running transaction check
---> Package candlepin.noarch 0:4.0.6-1.el7 will be erased
--> Processing Dependency: candlepin = 4.0.6-1.el7 for package: candlepin-selinux-4.0.6-1.el7.noarch
--> Processing Dependency: candlepin >= 2.0 for package: katello-
--> Running transaction check
---> Package candlepin-selinux.noarch 0:4.0.6-1.el7 will be erased
--> Processing Dependency: candlepin-selinux >= 3.1.10 for package: katello-selinux-4.0.0-1.el7.noarch
---> Package katello.noarch 0: will be erased
--> Running transaction check
---> Package katello-selinux.noarch 0:4.0.0-1.el7 will be erased
--> Finished Dependency Resolution

We have updated Candlepin to use Java 11 via the installer but I’m not sure we did the same in packaging. Also Puppetserver requires Java 8. Sadly, there is no common provides that a package can use that says “use Java 8 or Java 11” so it’s really painful to solve.