Unable to Start Foreman 1.1 RC4

> Hi All,
>
> After upgrading to Puppet 3.0.2 was having problems starting Foreman. I
> have since installed Foreman 1.1RC4 + dependencies in an attempt to get the
> Foreman console back.
>
> When try to start I am getting the following error:
>
> [root@…]# service foreman start
> Starting foreman: /usr/share/foreman/config/application.rb:22: undefined
> method config' for #<Rails::Paths::Root:0x7f4eadfe07b0> (NoMethodError) > from > /usr/lib/ruby/gems/1.8/gems/railties-3.2.9/lib/rails/commands.rb:53:in >require'
>
You are using rails 3.2.9, how did you install?
Foreman currently works with rails 3.0.17/18.

Ohad

··· On Mon, Jan 7, 2013 at 8:23 AM, Luke Vidler wrote:
    from

/usr/lib/ruby/gems/1.8/gems/railties-3.2.9/lib/rails/commands.rb:53
from
/usr/lib/ruby/gems/1.8/gems/railties-3.2.9/lib/rails/commands.rb:50:in tap' from /usr/lib/ruby/gems/1.8/gems/railties-3.2.9/lib/rails/commands.rb:50 from /usr/share/foreman/script/rails:6:inrequire’
from /usr/share/foreman/script/rails:6
[FAILED]

I tried installing adding and removing railties rubygems to no avail.

Can anyone shed some light or recommend a next step??

Thanks Luke.


You received this message because you are subscribed to the Google Groups
"Foreman users" group.
To view this discussion on the web visit
https://groups.google.com/d/msg/foreman-users/-/x5ucS0Ca70kJ.
To post to this group, send email to foreman-users@googlegroups.com.
To unsubscribe from this group, send email to
foreman-users+unsubscribe@googlegroups.com.
For more options, visit this group at
http://groups.google.com/group/foreman-users?hl=en.

Hi Ohad,

Thanks for your response. I was using the repos that Sam posted and
installing the rpm's individually. I tried to downgrade the rails gem but I
was still getting errors.

Is there are better way to install RC4 of Foreman?

··· On Monday, January 7, 2013 5:42:02 PM UTC+11, ohad wrote: > > > > > On Mon, Jan 7, 2013 at 8:23 AM, Luke Vidler <luke....@gmail.com > > wrote: > >> Hi All, >> >> After upgrading to Puppet 3.0.2 was having problems starting Foreman. I >> have since installed Foreman 1.1RC4 + dependencies in an attempt to get the >> Foreman console back. >> >> When try to start I am getting the following error: >> >> [root@....]# service foreman start >> Starting foreman: /usr/share/foreman/config/application.rb:22: undefined >> method `config' for # (NoMethodError) >> from >> /usr/lib/ruby/gems/1.8/gems/railties-3.2.9/lib/rails/commands.rb:53:in >> `require' >> > You are using rails 3.2.9, how did you install? > Foreman currently works with rails 3.0.17/18. > > Ohad > >> from >> /usr/lib/ruby/gems/1.8/gems/railties-3.2.9/lib/rails/commands.rb:53 >> from >> /usr/lib/ruby/gems/1.8/gems/railties-3.2.9/lib/rails/commands.rb:50:in `tap' >> from >> /usr/lib/ruby/gems/1.8/gems/railties-3.2.9/lib/rails/commands.rb:50 >> from /usr/share/foreman/script/rails:6:in `require' >> from /usr/share/foreman/script/rails:6 >> [FAILED] >> >> I tried installing adding and removing railties rubygems to no avail. >> >> Can anyone shed some light or recommend a next step?? >> >> Thanks Luke. >> >> -- >> You received this message because you are subscribed to the Google Groups >> "Foreman users" group. >> To view this discussion on the web visit >> https://groups.google.com/d/msg/foreman-users/-/x5ucS0Ca70kJ. >> To post to this group, send email to forema...@googlegroups.com >> . >> To unsubscribe from this group, send email to >> foreman-user...@googlegroups.com . >> For more options, visit this group at >> http://groups.google.com/group/foreman-users?hl=en. >> > >

Can you send the output of yum repolist? If your Foreman machine just has EPEL and the standard CentOS repo or RHEL with the optional channel enabled then the most version of Rails you should get via RPM is 3.0.17 from the RC repo.

··· ----- Original Message ----- From: "Luke Vidler" To: foreman-users@googlegroups.com Sent: Monday, January 7, 2013 7:44:07 PM Subject: Re: [foreman-users] Unable to Start Foreman 1.1 RC4

Hi Ohad,

Thanks for your response. I was using the repos that Sam posted and installing the rpm’s individually. I tried to downgrade the rails gem but I was still getting errors.

Is there are better way to install RC4 of Foreman?

On Monday, January 7, 2013 5:42:02 PM UTC+11, ohad wrote:

On Mon, Jan 7, 2013 at 8:23 AM, Luke Vidler < luke....@gmail.com > wrote:

Hi All,

After upgrading to Puppet 3.0.2 was having problems starting Foreman. I have since installed Foreman 1.1RC4 + dependencies in an attempt to get the Foreman console back.

When try to start I am getting the following error:

[root@…]# service foreman start
Starting foreman: /usr/share/foreman/config/application.rb:22: undefined method config' for #<Rails::Paths::Root:0x7f4eadfe07b0> (NoMethodError) from /usr/lib/ruby/gems/1.8/gems/railties-3.2.9/lib/rails/commands.rb:53:inrequire’
You are using rails 3.2.9, how did you install?
Foreman currently works with rails 3.0.17/18.

Ohad

from /usr/lib/ruby/gems/1.8/gems/railties-3.2.9/lib/rails/commands.rb:53
from /usr/lib/ruby/gems/1.8/gems/railties-3.2.9/lib/rails/commands.rb:50:in tap' from /usr/lib/ruby/gems/1.8/gems/railties-3.2.9/lib/rails/commands.rb:50 from /usr/share/foreman/script/rails:6:inrequire’
from /usr/share/foreman/script/rails:6
[FAILED]

I tried installing adding and removing railties rubygems to no avail.

Can anyone shed some light or recommend a next step??

Thanks Luke.


You received this message because you are subscribed to the Google Groups “Foreman users” group.
To view this discussion on the web visit https://groups.google.com/d/msg/foreman-users/-/x5ucS0Ca70kJ .
To post to this group, send email to forema...@googlegroups.com .
To unsubscribe from this group, send email to foreman-user...@googlegroups.com .
For more options, visit this group at http://groups.google.com/group/foreman-users?hl=en .


You received this message because you are subscribed to the Google Groups “Foreman users” group.
To view this discussion on the web visit https://groups.google.com/d/msg/foreman-users/-/nBASz7i1J9AJ .
To post to this group, send email to foreman-users@googlegroups.com.
To unsubscribe from this group, send email to foreman-users+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/foreman-users?hl=en.

Hi Sam,

Please see below:

repo id repo name

status
epel Extra Packages
for Enterprise Linux 6 - x86_64
8,284
puppetlabs-deps Puppet Labs
Dependencies El 6 - x86_64
29
puppetlabs-products Puppet Labs
Products El 6 - x86_64
159
rhel-x86_64-server-6 Red Hat
Enterprise Linux Server (v. 6 for 64-bit x86_64)
8,810
rhel-x86_64-server-optional-6 RHEL Server
Optional (v. 6 64-bit x86_64)
5,450
vmware-tools VMware Tools
latest - rhel6 x86_64
43
repolist: 22,775

Tks.

··· On Tue, Jan 8, 2013 at 1:10 PM, Sam Kottler wrote:

Can you send the output of yum repolist? If your Foreman machine just
has EPEL and the standard CentOS repo or RHEL with the optional channel
enabled then the most version of Rails you should get via RPM is 3.0.17
from the RC repo.

----- Original Message -----
From: “Luke Vidler” luke.vidler@gmail.com
To: foreman-users@googlegroups.com
Sent: Monday, January 7, 2013 7:44:07 PM
Subject: Re: [foreman-users] Unable to Start Foreman 1.1 RC4

Hi Ohad,

Thanks for your response. I was using the repos that Sam posted and
installing the rpm’s individually. I tried to downgrade the rails gem but I
was still getting errors.

Is there are better way to install RC4 of Foreman?

On Monday, January 7, 2013 5:42:02 PM UTC+11, ohad wrote:

On Mon, Jan 7, 2013 at 8:23 AM, Luke Vidler < luke....@gmail.com > wrote:

Hi All,

After upgrading to Puppet 3.0.2 was having problems starting Foreman. I
have since installed Foreman 1.1RC4 + dependencies in an attempt to get the
Foreman console back.

When try to start I am getting the following error:

[root@…]# service foreman start
Starting foreman: /usr/share/foreman/config/application.rb:22: undefined
method config' for #<Rails::Paths::Root:0x7f4eadfe07b0> (NoMethodError) from /usr/lib/ruby/gems/1.8/gems/railties-3.2.9/lib/rails/commands.rb:53:inrequire’
You are using rails 3.2.9, how did you install?
Foreman currently works with rails 3.0.17/18.

Ohad

from /usr/lib/ruby/gems/1.8/gems/railties-3.2.9/lib/rails/commands.rb:53
from
/usr/lib/ruby/gems/1.8/gems/railties-3.2.9/lib/rails/commands.rb:50:in tap' from /usr/lib/ruby/gems/1.8/gems/railties-3.2.9/lib/rails/commands.rb:50 from /usr/share/foreman/script/rails:6:inrequire’
from /usr/share/foreman/script/rails:6
[FAILED]

I tried installing adding and removing railties rubygems to no avail.

Can anyone shed some light or recommend a next step??

Thanks Luke.


You received this message because you are subscribed to the Google Groups
"Foreman users" group.
To view this discussion on the web visit
https://groups.google.com/d/msg/foreman-users/-/x5ucS0Ca70kJ .
To post to this group, send email to forema...@googlegroups.com .
To unsubscribe from this group, send email to
foreman-user...@googlegroups.com .
For more options, visit this group at
http://groups.google.com/group/foreman-users?hl=en .


You received this message because you are subscribed to the Google Groups
"Foreman users" group.
To view this discussion on the web visit
https://groups.google.com/d/msg/foreman-users/-/nBASz7i1J9AJ .
To post to this group, send email to foreman-users@googlegroups.com.
To unsubscribe from this group, send email to
foreman-users+unsubscribe@googlegroups.com.
For more options, visit this group at
http://groups.google.com/group/foreman-users?hl=en.


You received this message because you are subscribed to the Google Groups
"Foreman users" group.
To post to this group, send email to foreman-users@googlegroups.com.
To unsubscribe from this group, send email to
foreman-users+unsubscribe@googlegroups.com.
For more options, visit this group at
http://groups.google.com/group/foreman-users?hl=en.