Unable to sync some RH repositories

**Problem:When trying to sync some of the Red Hat repositories the sync ends with warning and contents are not available

**Expected outcome:*All content *

**Foreman and Proxy versions:foreman-2.5.4-1.el7.noarch

**Foreman and Proxy plugin versions:katello-4.1.4-1.el7.noarch

**Distribution and version:RHEL 7.9

*Other relevant data:

Exception in /var/log/messages: 
Dec 28 18:37:48 mtsforeman pulpcore-api: [2021-12-28 18:37:48 +0100] [18287] [CRITICAL] WORKER TIMEOUT (pid:18320)
Dec 28 18:37:50 mtsforeman pulpcore-api: [2021-12-28 18:37:50 +0100] [18287] [WARNING] Worker with pid 18320 was terminated due to signal 9

Exception in /var/log/foreman/production.log
2021-12-28T18:37:18 [I|app|6d6b7c7f] CONTENT_INDEX type=Katello::Rpm success=false duration=60157.12
2021-12-28T18:37:18 [E|bac|6d6b7c7f] Error message: the server returns an error (PulpRpmClient::ApiError)

Do you have logs that looks like :

django.db.models.deletion.ProtectedError: (“Cannot delete some instances of model ‘ReservedResource’ because they are referenced through a protected foreign key: ‘TaskReservedResource.resource’”


I looked at messages and production logs but I didn’t find the entry mentioned.
Today seems I solved the exception related to the timeout simply increasing the value in the service (/etc/systemd/system/pulpcore-api.service).
But I sttil have the exception related to the Actions::Katello::Repository::IndexContent.
I completely removed and added the product, changed download policy, refreshed metadata but the issue is the same. This issue appens only for a pair of RHEL product. I synced others without errors

Hi, do you have any idea?
Now the sync finish with no issue, but I can’t see any packages, errata etc… for the product.

Thanks and regards

I have those errors you mentioned in my messages file.
Any idea what is going on?
Any help on how to solve that would be highly appreciated.

Hi, you can check my answer here, it should fix your problems

You can check out the thread to get more information about it.
I also ran foreman-installer --foreman-proxy-content-enable-katello-agent=false to remove any traces of the Katello agent as I didn’t use it. You should do that as well if you don’t use the katello agent

@ivan Have you tried recreating the repository maybe ? Is your repository download_policy set to immediate ?

Hi, that solved my issue.

thanks for your help.

Hi, yes I’ve already deleted e re-added the repository. Initially the download policy was “On demand”. Then I changed to immediate. But the issue still persist.

To finish the task, through dynaflow console, I forced to skip the failed step “IndexContent”
Doing so, the sync tasks finish but I’ve no visible packages, errata etc…, in the RHEL 7 Server product page.
Anyway the clients seem succesfully retrieve the updates and packages from Foreman

Thanks and regards

Hello, the issue has been solved setting “Pulp bulk load size” to 700 instead of default value, 2000