Unable to sync the Mozilla ppa repository

Problem: Sync of Mozilla ppa repository (for Ubuntu) fails

Expected outcome: Sync works

Foreman and Proxy versions: 3.7 + katello 4.9.1

Foreman and Proxy plugin versions:

Distribution and version: RedHat 8

Other relevant data: I already mirror the Ubuntu 22 repository with success. Try to do the same thing with the Mozilla repo but get this error : “No valid Release file found for ‘jammy’.”

Hey there!

I tried to get it working out of curiousity, looks like the following config worked for me:

Upstream URL: https://ppa.launchpadcontent.net/mozillateam/ppa/ubuntu
Releases/Distribution: jammy
Components: main
Architectures: amd64

Hope that helps!

1 Like

I’ve exactly the same config for the repo, and the result is :
No valid Release file found for ‘jammy’.


We have recently improved that very error message to give better hints of what went wrong, but Katello 4.9, does not have that fix yet. :disappointed:

Are you using “Content Credentials” to verify the signature of the upstream repository you are syncing?
If you are, pulp_deb will discard any Release files, it cannot verify, so a configuration error in the “Content Credential” being used, could lead to the error you have posted.


Note: I will try to backport the error message improvements to the release branch used by Katello 4.9: [PR #733/b23d67d1 backport][2.20] Improve "No valid Release file found" error message by patchback[bot] · Pull Request #885 · pulp/pulp_deb · GitHub

Unfortunately it will require some time before this is actually released, and packaged for the relevant Katello 4.9 repository.

1 Like

You were right !
I removed the GPG key associated to the repo and it works.
Thanks !!