"Update All Packages button" grayed out

On Foreman 3.2/Katello and when I go “Content Hosts”, click a host with available packages to upgrade, select “Packages, Applicable” I come to a list of packages I can upgrade. To the far right there is a button that says “Update All Packages” that is greyed out.

I do not seem to manage to activate or use this button in anyway, always greyed out. Can someone explain how this should be used?

Looking at the code,

"remoteExecutionByDefault || !katelloAgentPresent || working"

If the button doesn’t get enabled, I’d assume your system is set to use remote execution by default or katello agent is not present on the system.

OK, thanks for the clarification, not totally clear that is a “katello agent only” button.
I guess I assumed it was there to make it faster to actually update all upgradeable packages in the list with one click instead of first selecting all of them.

You can do that from the “Content Hosts” list, selecting the host(s) you want and then using the “Manage Packages” action.

If you’re using remote execution, try out the Content > Packages tab in the new host details page (Hosts > All hosts > <your_host> > New UI) You can filter the list to “Upgradable”, then select all with the checkbox at the top, then click Upgrade. If all packages are selected, it’s smart enough to just run yum update on the host rather than specify the individual packages.

1 Like