Update All Packages still using katello agent even though default is remote execution


I just wanted to update all applicable packages on a content host, thus I click on “Update All Packages” on the applicable packages page of the content host. However, it timed out after 20s. It seems to use katello agent even though I have changed the default in settings to remote execution.

I then selected all applicable packages on the page and pressed the upgrade selected button which automatically used remote execution and upgraded the packages.

It seems to me update all packages uses katello agent while upgrade selected uses remote execution as it should.

Foreman and Proxy versions:

2.2.1 & Katello 3.17

Distribution and version:

CentOS 7.9

Unfortunately its same in Katello 3.18.1. It is possible change it in configuration or is bug?