Update facter Puppet

hi all,
I have in a module in Puppet, so far it works.

But I modfiy the fact_file.rb and go to foreman Puppet Classes and import from environment server, I get the message: Info alert:No changes to your environments detected

And when I pull from client the old fact_file.rb is still there without my changes!

What should I do here so that Foreman send also my new changes ?

Thanks in advance


The message is correct, as it only checks for the “interface” (classes and their parameters) which is relevant for Foreman as an ENC.

So this should not influence the plugin sync happening at the beginning of a puppet run. Do you work with multiple environments? If I am correct Puppet has still some problems here and is always syncing the plugins (facts and functions) from productions, but I am not sure if this got really fixed in the latest versions.


Thanks for your answer @Dirk,

I have only one environment. That works before I install foreman very good.
So I install foreman on my server and it works, but the module/mymodule/lib/facter/fact_file.rb will not updated now!

I reseted both and still same thing! I delete the file fact_file.rb on the client and when I pull I get still the old one! why and where is that? does foreman create caching for that or so?

Puppetserver has introduced an environment cache, this could be also the cause.

I have not looked deeper into this, but there should simply be the option to delete it on the server somewhere below /opt/puppetlabs/ or an CLI or API option to do this in a clean way.

Yes thats right, I clear the directory and I restart puppetserver and its still the same problem!

Does foreman have a cache ? if yes where and how can we clear it ?

Foreman is not involved here, it is really only the Puppetserver.
But if it is not the cache or environments leaking, I am out of ideas. :frowning:

1 Like

Before I install foreman on the server it works normal! Because of that I say maybe something related to foreman!

anyway thank you for your answers.