Upgrading from foreman 3.0 to foreman 3.1 and katello 4.2 to 4.3

Problem:
After running:
yum update -y https://yum.theforeman.org/releases/3.1/el7/x86_64/foreman-release.rpm
yum update -y https://yum.theforeman.org/katello/4.3/katello/el7/x86_64/katello-repos-latest.rpm
yum install -y centos-release-scl-rh
yum clean all
yum -y update

I get:

→ Finished Dependency Resolution
Error: Package: python3-pulp-2to3-migration-0.12.0-2.el7.noarch (@pulpcore)
Requires: python3-pulpcore < 3.15
Removing: python3-pulpcore-3.14.9-1.el7.noarch (@pulpcore)
python3-pulpcore = 3.14.9-1.el7
Obsoleted By: tfm-pulpcore-python3-pulpcore-3.16.1-1.el7.noarch (pulpcore)
Not found
Error: Package: python3-pulp-2to3-migration-0.12.0-2.el7.noarch (@pulpcore)
Requires: python3-pulpcore >= 3.13
Removing: python3-pulpcore-3.14.9-1.el7.noarch (@pulpcore)
python3-pulpcore = 3.14.9-1.el7
Obsoleted By: tfm-pulpcore-python3-pulpcore-3.16.1-1.el7.noarch (pulpcore)
Not found
You could try using --skip-broken to work around the problem

Foreman and Proxy versions:
3.0.1

Foreman and Proxy plugin versions:
foreman-tasks 5.1.1
foreman_cocker 5.0.0
foreman_puppet 1.0.5
foreman_remote_execution 4.8.0
katello-4.2.1

Distribution and version:
CentOS Linux release 7.9.2009 (Core)

Just to chime in, I encountered the same issue this morning with an attempted upgrade of the same version as noted in the previous post as well.

Fixed it by removing package python3-pulp-2to3-migration from the server.

Since your already running Foreman 3.0.x, makes sense that you won’t be doing any pulp2 to pulp3 migrations and as the name of the package suggests, that is what it supports.

Probably a package that should have been cleaned up during a past upgrade or the process to remove pulp2 support from your install.