User dropdown shifted to the left after upgrade to 3.8

Hey there!

As you can see in this picture, it looks like something got missing :slightly_smiling_face:
Spun up a machine with Forklift (katello-devel with stable repos) and there it sticks to the right edge, so not sure if this is expected.
Also recovered with a snapshot and did the upgrade a 2nd time to make sure it’s not me doing something weird.

Foreman and Proxy versions:

3.7/4.9 → 3.8/4.10

Foreman and Proxy plugin versions:

Snapshot Management

Distribution and version:

Rocky Linux 8

If anything else could be helpful here, will sure provide it!

I see what you’re saying-- the ‘Admin User’ and notification bell should be all the way to the right, but they’re not.

Hm, my dev setup on the 3.8-stable and KATELLO-4.10 branches looks normal. :person_shrugging:

Perhaps it’s one of the plugins?

1 Like

I’m seeing the same thing:

Here are my plugins:

I’m on CentOS-8 Stream, and installed from packages from the repo

@lumarel is your Katello also rc2?

Yeah same, this is what confuses me so much, Forklift katello-devel with 3.8-stable + KATELLO-4.10 doesn’t give me the same result.

Yes you are right, I only just noticed that it’s indeed:

  • foreman 3.7.0-1 → 3.8.0-0.1.rc2
  • katello 4.9.2-1 → 4.10.0-0.2.rc2

Tried to figure out where it is coming from but didn’t really see it, it definitely looks like there is a justify-content: flex-start or unset somewhere :thinking:

fyi: Katello 4.10.0 is now available - #2 by damoore

Let’s see if this issue persists after Foreman 3.8 and Katello 4.10 GA are actually available.


The same issue with


Yeah waiting for Katello 4.10 to drop and then I will also retry :slight_smile:

Is it still not available? I thought it should be out now, per the community demo announcement…

cc @iballou

This was actually the reason why I started looking again :slightly_smiling_face:
Looking at the repo content right now it’s not there, and looking at this release team meeting, the PRs are still open.

That was my bad, I thought our RPMs were out and we were just waiting on Foreman to release, so in my head Foreman 3.8 being GA == Katello 4.10 being GA. So yeah @lumarel is right, we’re still waiting on packages for Katello 4.10.

1 Like

Today i upgrade to katello-4.10.0-1 foreman-3.8.0-1 and still looking the same

This div should have the pf-m-align-right class, which gives it justify-content: flex-end;. Does it?

I see that

After the release announcement now, also did another upgrade!
Here is the result on my side:


Also, manually adding the flex-end in this div doesn’t do much.

Hah! Found it! is missing a width: 100%


cc @MariaAga , any idea where this could be coming from?

Yeah, foreman-bootdisk wasn’t released in a long time and was built using old foreman css (which cause the user dropdown to be on the left). it should be fixed by updating foreman-bootdisk
Related pr: Update foreman-bootdisk to 21.1.0 by stejskalleos · Pull Request #9744 · theforeman/foreman-packaging · GitHub