User role filter for host values not working properly

Even though configured, user cannot view host facts ( but can access the Fact Values interface, just get no facts/values )

Expected outcome:
User should be able to view host facts

Foreman and Proxy versions:
Foreman 1.22
Katello 1.12

Foreman and Proxy plugin versions:

Other relevant data:
[e.g. logs from Foreman and/or the Proxy, modified templates, commands issued, etc]
(for logs, surround with three back-ticks to get proper formatting, e.g.)
All filters on role:

Am i missing some filter or is this particular filter bugged?

Can you verify if you as admin see the values in the same context the users are located in? Or can you only access them in the “Any organization” and “Any location” context? If I remember correctly I have seen this behaviour in the past and would hope this is gone with 1.23.

On my user i can see the facts in both the correct location/org aswell as any/any.
Added view organization and view location roles to user to verify that he is, in fact, in the correct organization and location contexts.
Everything looks right, but still no facts - i can see all the hosts correctly, with parameters and such, and can even click the Fact button on each hosts page, just cannot get fact value read permission to work correctly.

If this is a bug that’s resolved in 1.23 then i guess i will just have to wait a couple weeks more to test my program properly.

If it has nothing to do with the context, it is not what I was thinking about. Testing with 1.23 would still be a good idea, but not sure if there was an issue and fix similar to this.

When viewing the facts page that is showing up empty, are there any errors either in the browser console or the server production.log?

Nothing in console and production.log just says everything is OK, completed 200 for request and no errors

could you check if marking the fact value filter as unlimited has any affect?

I had tried that already, but checking Unlimited and saving says that it saved successfully but when i go back to filters, the checkmark isn’t showing

This sounds like possibly Bug #7349: Unlimited Setting in Filters Should Grey Out Organization & Location Tab - Foreman - check the org/loc tab inside the filter and make sure none are selected

The fact_value filter didn’t have any org/loc tabs in it, but the role itself had them assigned.
After removing them from the role, all filters became unlimited and i got the fact values to show up. So this seems to have fixed my issue.
I would have thought that since the hosts are in this particular org/loc that i would then also be able to see the facts for these same hosts. Seeing as i only have the one org/loc in my system this isn’t much of a problem for me, specifically, but may very well be for others who need to be able to segment access to facts based on which org/loc the host is based in.

That does indeed sound like a bug, please open an issue on our tracker with the findings we’ve had here.