Version 1.23.1 - Unable to assign more than 10 ansible roles in GUI

Hi All,

In the foreman gui, I create a new hostgroup. I go to assign ansible roles and when i hit 10 roles, I can’t add anymore. I kinda need all of them…

Any idea what’s up or if there is a fix, to be able to assign more than 10 roles?

I believe this worked in 1.22.x. I don’t think it’s a good idea to downgrade, so any help with my version or a new one is greatly appreciated.


It appears most of my issues deal with host groups. If I make a change to an existing host group everything comes back wrong. All my ansible roles are dropped, I can no longer set provisioning templates. I can provision hosts.

Any help with this is really appreciated. I need to get something working and something as trivial as imaging a host not working is really frustrating.


I believe this is fixed in foreman_ansible 4.0.4, check if the symptoms are the same as described in Bug #28463: Associating more than 10 Ansible roles to a Host only sets based on the per-page setting - Ansible - Foreman. You’d need to update your Foreman to 1.24 (good idea anyway)

Yeah that pretty much sums it up.



I think the upgrade to 1.24.2 worked well. I just ran it through it’s paces and checked other known issues that every time I upgrade seem to have.

Hopefully I don’t run into any new ones, but the basics seem to work:

  1. provision
  2. add hosts
  3. manage hosts and ansible configurations

Thanks for the help.
This can be closed