VMWare finish script problem (was: Foreman-debug -u)


I tried to uploaded, but we have filters. Let me know that status of this configuration, please@!

[root@foreman ~]# foreman-debug -u
Processing… (takes a while)

HOSTNAME: foreman.eng.stellus.in
OS: redhat
RELEASE: CentOS Linux release 7.3.1611 (Core)
FOREMAN: 1.17.4
RUBY: ruby 2.0.0p648 (2015-12-16) [x86_64-linux]
PUPPET: 5.5.2

A debug file has been created: /tmp/foreman-debug-SSxct.tar.xz (1757424 bytes)

rsync: failed to connect to theforeman.org ( Connection timed out (110)
rsync error: error in socket IO (code 10) at clientserver.c(125) [sender=3.1.2]
The tarball could not be uploaded, please upload it to an alternate location
and contact us on our mailing list or IRC referencing that URL.

(Attachment foreman-debug-SSxct.tar.xz is missing)

We had a short outage of our web server, try now. I see that rsync service is operating normally. In the worst case, just attach your debug to a new thread.

foreman-debug-1wpoM.tar.xz.tar (1.6 MB)

Remove the last .tar extension then you can un-compress the file. I’m still not able to upload the file. it might our filters.


Sure and the problem is? :wink:

Create Host => I’m trying to create a host via VMware template. I checked the Operating Systems, Computer Resource, Computer Profile, Templates, etc… When I try to save the host I receive an error: “No finish templates were found for this host, make sure you define at least one in your CentOS 7.3.16 settings”


Do what is says actually, associate your finish template with your OS, check organization and location if it matches if you enabled that. Finish template is mandatory for VMWare provisioning, unless you use seed scripts (user-data templates).