Vmware image-based provisioning issue


I'ven been following some guidelines i found here and started working with
a userdata template for the finishing of provisioning vmware templates
However i run in to these error at the moment and i dont get why actually:

Failed to create a compute XXXX instance XXXXX undefined method `length'
for nil:NilClass

I hope someone here can help me further…

ps: been using satellite 6.2

I ran into that exact same error just today and it ended up being a format
error in my user data template. It rendered fine in the web UI, but vmware
didn't like it for some reason. Here is the one I am currently using (in
Sat 6.2) which is working for me.

domain: <%= @host.domain%>
hostName: <%= @host.shortname%>

dnsServerList: [<%= @host.primary_interface.subnet.dns_primary %>, <%=
@host.primary_interface.subnet.dns_secondary %>]
dnsSuffixList: [<%= @host.domain %>]

<% @host.interfaces.each do |interface| %>

  • adapter:
    ip: <%= interface.ip %>
    subnetMask: <%= interface.subnet.mask %>
    <% if interface.primary -%>gateway: [<%= interface.subnet.gateway
    %>]<% end %>
    <% end %>