Warning over Puppet 3.5 and Facter 2 compatibility

Hi folks,

Just a heads up if you're looking to try the 3.5.0 or Facter 2.0.1
release candidates that there are some incompatibilities with Foreman.
I'd suggest waiting before you upgrade.

We've been working over the past few weeks to resolve these and are
close to releasing Foreman 1.4.2 with the necessary fixes. This should
be out before Puppet 3.5.0 final is released.


  • Foreman core requires Facter 1.x (except on EL6 due to SCL)
  • Foreman installer requires Facter 1.x
  • Smart proxy requires Puppet 3.4 or older

Tracker #4359: Puppet 3.5.0 support - Installer - Foreman links to specific fixes if
you're interested.

ยทยทยท -- Dominic Cleal Red Hat Engineering