Which node versions do we support?


our Contributing page says about supported Node.js versions:

In general, the latest stable Node.js should work. However if you are just starting out, you may want to develop against one of the versions that we test against to reduce the chances of you hitting an unexpected issue, although this is not required.

What are these versions?

I am trying out a fresh install and I have the latest and greatest 7.6.3 and getting:

lzap@mone foreman % npm install
npm ERR! code ERESOLVE
npm ERR! ERESOLVE unable to resolve dependency tree
npm ERR!
npm ERR! While resolving: TheForemanDevDeps@2.5.0
npm ERR! Found: react-dnd-test-backend@9.5.1
npm ERR! node_modules/react-dnd-test-backend
npm ERR!   dev react-dnd-test-backend@"^9.4.0" from the root project
npm ERR!
npm ERR! Could not resolve dependency:
npm ERR! peer react-dnd-test-backend@"^7.2.0" from react-dnd-test-utils@9.5.1
npm ERR! node_modules/react-dnd-test-utils
npm ERR!   dev react-dnd-test-utils@"^9.4.0" from the root project
npm ERR!
npm ERR! Fix the upstream dependency conflict, or retry
npm ERR! this command with --force, or --legacy-peer-deps
npm ERR! to accept an incorrect (and potentially broken) dependency resolution.


ha, latest and greatest is 15.11.0, I think that 7.x is older than rhel :slight_smile:

1 Like

Right now, if i’m not mistaken, we’re building with Node 10, and testing with Node 12 and 14. I belive @ehelms is looking into updating our builders to also use 14.

Thanks it looks like v14 works fine but v15 does not. That will do it.

Bumping it after seeing in IRC that node 16 fails.
Looks like we cant use node 16 until we update webpack.
node-sass only supports node 16 from node-sass v6.0,
but sass-loader only supports node-sass v6 from sass-loader v11.1.0
and sass-loader v11.0.0 only supports wepack 5 (or heigher)