our Contributing page says about supported Node.js versions:
In general, the latest stable Node.js should work. However if you are just starting out, you may want to develop against one of the versions that we test against to reduce the chances of you hitting an unexpected issue, although this is not required.
What are these versions?
I am trying out a fresh install and I have the latest and greatest 7.6.3 and getting:
lzap@mone foreman % npm install npm ERR! code ERESOLVE npm ERR! ERESOLVE unable to resolve dependency tree npm ERR! npm ERR! While resolving: TheForemanDevDeps@2.5.0 npm ERR! Found: email@example.com npm ERR! node_modules/react-dnd-test-backend npm ERR! dev react-dnd-test-backend@"^9.4.0" from the root project npm ERR! npm ERR! Could not resolve dependency: npm ERR! peer react-dnd-test-backend@"^7.2.0" from firstname.lastname@example.org npm ERR! node_modules/react-dnd-test-utils npm ERR! dev react-dnd-test-utils@"^9.4.0" from the root project npm ERR! npm ERR! Fix the upstream dependency conflict, or retry npm ERR! this command with --force, or --legacy-peer-deps npm ERR! to accept an incorrect (and potentially broken) dependency resolution.