Windows 10 Provisioning

I’am currently trying to get Windows10 provisioning to work on my foreman host.
I created the boot.wim (once with WIMan which failed with some errors that probably have to
do with the windows10 Iso changing from install.wim to install.esd … and once by hand according to this: How to create an unattended installation of Windows 10 | Windows Central tutorial)
Both times I ran into the same error that foreman was seemingly partitioning the disks and then just stopped without giving any error message. (logs appear to be empty aswell).
Weirdly enough it shows up as ‘installed’ in foreman after around 2 minutes.
I’am using ipxe.lkrn to preboot and download the relevant data from foreman onto the machine.
I’am probably missing some obvious step here OR my image is corrupt or does not work as intented.
Maybe someone has more expirience in getting Windows10 to work with foreman.

Expected outcome:
Installing Windows 10 on Machines tagged with Operating System: $Windows10

Foreman and Proxy versions:
Foreman version 2.3.2
Smartproxy version 1.24.3

Foreman and Proxy plugin versions:
foreman-tasks 3.0.2
foreman_bootdisk 17.0.2
foreman_default_hostgroup 5.0.0
foreman_dhcp_browser 0.0.8
foreman_discovery 16.3.4
foreman_remote_execution 4.2.1
foreman_setup 7.0.0

Distribution and version:
Linux Centos7
11gb memory
50gb Diskspace
4 CPU’s

Thank you in advance for your help, hopefully those are all the Information needed.
If not let me know and I will provide what is missing!