Wrong puppetmaster in YAML afer upgrade from 1.23 to 1.24

Problem:
After upgrading from 1.23 to 1.24 on Debian. The “puppetmaster:” in the yaml is not the “Puppet Master” selected on the Host tab.

We have a single foreman instance + smart proxy that has “BMC, DHCP, DNS, Logs, Puppet, Puppet CA, and TFTP” enabled.

And in some remote locations additional proxies with just “Puppet and TFTP”.

We generally set the “Puppet Master” to the closest proxy. The “puppetmaster” variable is then used to configure the “server” in puppet.conf. This no longer works now. All hosts are being configures to use the same proxy on the main server.

Maybe I overlooked something but while going trough the release notes noting jumped out that explains this.

Expected outcome:
Use the configured setting.

Foreman and Proxy versions:
1.24

Foreman and Proxy plugin versions:

Distribution and version:
Debian Stretch.

Other relevant data:

In Foreman 1.24 we started to use the puppet_url configured on the Smart Proxy rather than the hostname of the Smart Proxy itself. Are those all pointing to the same instance by any chance?

1 Like