Yum -y install foreman-installer gives error

> Hello, i tried to install foreman, but then I tried tu run yum -y
> install foreman-installer in the end i get error.
> Thanks for any help.
> [root@localhost osva]# yum -y install foreman-installer
> Loaded plugins: fastestmirror, refresh-packagekit, security
> Loading mirror speeds from cached hostfile
> * base: mirror.ox.ac.uk <http://mirror.ox.ac.uk/>
> * extras: mirror.econdc.com <http://mirror.econdc.com/>
> * updates: mirror.vorboss.net <http://mirror.vorboss.net/>

> Error: Package: 1:foreman-installer-1.7.3-1.el6.noarch (foreman)
> Requires: puppet >= 2.7.0
> Error: Package: rubygem-rest-client-1.6.7-2.el6.noarch (foreman)
> Requires: rubygem(mime-types) >= 1.16

It looks like you're missing the EPEL repository. Run this to configure it:

yum -y install epel-release

I'd also recommend enabling the Puppet Labs repository to get a more
recent version of Puppet.

rpm -ivh http://yum.puppetlabs.com/puppetlabs-release-el-6.noarch.rpm

These steps can also be found in our quickstart guide:

··· On 11/03/15 10:46, Osvaldas Šlapikas wrote:

Dominic Cleal
Red Hat Engineering