Content host shows installable updates (package updates) that are already installed and running

Problem: Content host shows installable updates (package updates) that are already installed and running

Expected outcome: All packages installed and Installable updates = 0

Foreman and Proxy versions: Foreman 2.1.2 With Katello 3.16

Foreman and Proxy plugin versions: 2.1.2

Distribution and version: Centos 8.2.2004

Other relevant data:

Hi everyone im currently testing Foreman with Katello as a replacement for our Spacewalk installation.
And i ran into this issue when patching a CentOS 8.2 server.
Before patching the server showed 300ish installable updates, after patching and reboot there is still 3 Installable updates:
kernel, kernel-core and kernel-modules
When i check the server that kernel version is running and dnf update shows no availabe patches.

Anyone got any idea why katello still shows those packages as updates when they are running on the server?

Command issued: dnf update -y and reboot after

Hmm checking today and available updates are now 0, is there some scheduled task that could have fixed it?

I was hoping to reach out to you before something like this happened. I was curious to see, when looking at the installed packages for you Content Host in Katello itself, which versions of the above packages were installed. The goal would have been to see if Katello knew that the new packages were on your client host. If not, that would have explained the behavior. Although, after any dnf action which modifies the packages on the host, the data should get updated in Katello. What fixed it was likely the periodic (every 4 hours by default) checkin that happens from all registered Content Hosts.

Let me know if you see it on any of your other hosts, and check on what I mentioned above if you can.


I installed a new CentOS 8 server patched and rebooted it and got the same result, 3 available package upgrades

Upgradable Package


When searching the content host for installed packages named 4.18.0-193.19.1 i get this list:


So Katello knows that the packages are installed and still marks them as upgrades.

Is there a way on the content host to do a manual checkin like the old rhn_check command?
To see if it was the scheduled checkin that updated the upgradable package list.


  • At the time you installed the packages, was there a Combined Profile Update for <host> under Monitor -> Tasks ?
  • Which version of subscription-manager is installed on your EL8 client?

Run patch job 07:08 PM
Combined Profile Update 07:16 PM

Since the patching of 322 packages took a few minutes is looks like there was a combined profile update job running at the same time.

Version of installed subscription-manager is 1.26.20-1.el8_2

The second server i installed still have 3 available package updates after the patching last night.
So the automatic checkin did not update the installable update list.

Thank you for all of the great details! I was able to reproduce the problem and seems like a legitimate issue, so I filed it on your behalf: Bug #30964: Applicable packages sometimes reported incorrectly - Katello - Foreman I marked it for inclusion in 3.16.2

I am not aware of any workaround at this time.

Awsome thank you for your help!