Error during foreman-installer execution

Hi all,
I have to confess that I am a complete newbie regarding foreman/katello, just wanted to try it out to manage some boxes that host RHELs. So please, go easy on me :slight_smile: Thanks

During foreman-installer execution with scenario katello I get this error:

2021-04-07 15:58:20 [ERROR ] [configure] /Stage[main]/Foreman::Database/Foreman::Rake[db:seed]/Exec[foreman-rake-db:seed]: Failed to call refresh: ‘/usr/sbin/foreman-rake db:seed’ returned 1 instead of one of [0]
2021-04-07 15:58:20 [ERROR ] [configure] /Stage[main]/Foreman::Database/Foreman::Rake[db:seed]/Exec[foreman-rake-db:seed]: ‘/usr/sbin/foreman-rake db:seed’ returned 1 instead of one of [0]

Sidenote: also had a problem with squid, but that was solved rerunning the installer (it seems that if the directory of var/spool/squid already exists it returns permision error; had it created already to mount a fresh block on it because of space)

So now I will try to get any ideaof what is wrong with rake, before running the installer again.
Thank you very much for any idea and sorry if this was already discussed or if it seems too obvious, as said, it is my first approach to this tool.

Thanks and cheers

Expected outcome:
Clean installation log

Foreman and Proxy versions:


Foreman and Proxy plugin versions:

2.3 I guess

Distribution and version:

Other relevant data:

You can run /usr/sbin/foreman-rake db:seed which it is complaining about in the shell and it should produce some stacktrace which can help to debug the problem.

Hi Dirk,

thanks for the suggestion, this is the trace:

[root@vm-p-isvp-gpv01 ~]# foreman-rake db:seed --trace
** Invoke db:seed (first_time)
** Invoke db:load_config (first_time)
** Invoke environment (first_time)
** Execute environment
Apipie cache enabled but not present yet. Run apipie:cache rake task to speed up API calls.
** Execute db:load_config
** Execute db:seed
** Invoke db:abort_if_pending_migrations (first_time)
** Invoke db:load_config
** Execute db:abort_if_pending_migrations
** Invoke dynflow:abort_if_pending_migrations (first_time)
** Invoke environment
** Execute dynflow:abort_if_pending_migrations
User with login admin already exists, not seeding as admin.
rake aborted!
Foreman::Exception: ERF42-9500 [Foreman::Exception]: Unknown remote execution feature katello_module_stream_action
/opt/theforeman/tfm/root/usr/share/gems/gems/foreman_remote_execution-4.2.2/app/models/remote_execution_feature.rb:23:in feature' /opt/theforeman/tfm/root/usr/share/gems/gems/foreman_remote_execution-4.2.2/app/models/job_template.rb:171:in sync_feature’
/opt/theforeman/tfm/root/usr/share/gems/gems/katello- block (2 levels) in <top (required)>' /opt/theforeman/tfm/root/usr/share/gems/gems/audited-4.9.0/lib/audited/auditor.rb:376:in without_auditing’
/opt/theforeman/tfm/root/usr/share/gems/gems/katello- block in <top (required)>' /usr/share/foreman/app/models/concerns/foreman/thread_session.rb:108:in as’
/usr/share/foreman/app/models/concerns/foreman/thread_session.rb:114:in `as_anonymous_admin’

The Unknown remote execution feature katello_module_stream_action sounds like something is not matching or executed in wrong order and there is already an issue for it: Bug #31416: db seed fails with 'Unknown remote execution feature katello_module_stream_action' - Katello - Foreman

There is a fix included in Fixes #31416 - Make sure remote execution plugin is already loaded before katello by ShimShtein · Pull Request #9025 · Katello/katello · GitHub, can you test it? If it works this has to be backported to 3.18 and I will try to get someone to do it.

Thank you Dirk I will let you know when I can try it.


@maramorim has some login problems, but sent me an email to confirm this fixes the problem, so we need a backport here.

1 Like

The email, naturally, went to spam.
I will try to resolve this with @maramorim !


back to the saddle thanks to @mcorr :slight_smile: ty.

and I can confirm Dirk answer worked for me and the installer was able to finish. So thank you @Dirk :slight_smile:

1 Like