Foreman Installer Fails at about 80% complete -touch /var/lib/candlepin/cpinit_done' returned 8

katello
installer

#1

Problem:
Foreman Install Fails

Expected outcome:
Completed installation

Foreman and Proxy versions:
foreman-1.14.3-1
puppetserver-2.8.1-1
katello-3.3.2-1
foreman-installer-katello-3.3.1.4-1

Foreman and Proxy plugin versions:

Other relevant data:
I started the process to build the opensource version of Satellite (Foreman, Katello, Candelpin, Puppet, Pulp) and ran into some issues with the install. I began the process installing a brand new CentOS 7.x minimal server. I followed the directions listed here - https://github.com/lukepafford/iac_config/wiki/Install-Satellite-6-on-Centos-7.

The first issue I noticed was dependency resolution. When running yum -y install foreman-installer and yum -y install katello the system told me my version of python2-celery was too new. I needed to downgrade it. I ran yum remove python2-celery-4.2.1-3.el7.noarch. At this point I downloaded the version the system said it needed with a wget and performed a local install. #yum -y localinstall python-celery-3.1.11-1.el7.centos.noarch.rpm. I was able to get yum -y install foreman-installer and yum -y install katello to complete normally.

At this stage I moved to the installation of foreman-installer --scenario katello. The install gets to approximately 80% and fails. I have noted the following ERROR message repeatedly in the log.

[ERROR 2019-02-10 07:40:07 main] /Stage[main]/Candlepin::Service/Exec[cpinit]/returns: change from notrun to 0 failed: '/usr/bin/wget --no-proxy --timeout=30 --tries=40 --wait=20 --retry-connrefused -qO- http://localhost:8080/candlepin/admin/init > /var/log/candlepin/cpinit.log 2>&1 && touch /var/lib/candlepin/cpinit_done' returned 8 instead of one of [0]

I did some research and found this:
https://access.redhat.com/solutions/1123803 (steps 2, 3 and 4 were performed prior to install)
Install of Foreman-Katello fails at "/Stage[main]/Candlepin::Service/Exec[cpinit]: Starting to evaluate the resource"
Candlepin error on fresh install regarding certs

I reviewed and tried the suggestions in those articles without luck. Your input is greatly appreciated!

logs
http://batman.gyptis.org/zerobin/?b4c9db6ef678459a#6hPunIvpQWoCU2ah5hHjMYa8IVDuZotzRyuTqB6V9rQ=


#2

Hi,

a simple question befor starting to look at your problem itself:
Is there a specific reason you are trying to install Foreman 1.14 and Katello 3.3? Those releases are about 2 years old now (witch is probably why you had to downgrade some things manually).
If there is no reason and you simply installed because that’s what is stated in your linked documentation (which is obviously unmaintained) I would recommend trying an install current releases that have a ton of bugfixes built in and are tested on current CentOS installations.

The basic directions on how to install Katello and Foreman with current versions can be found here for Katello and here for plain Foreman. Remember that when installation Katello, you can not start with with a plain Foreman and later “upgrade” that, but you have to start directly with installing Katello. There are some tips in the Foreman docs though that are not in the Katello documentation.

If you do have a reason to install a somewhat ancient release, you should start by looking at the seperate init log that is mentioned in the error messages: /var/log/candlepin/cpinit.log


#3

Thanks areyus, I should have realized that there was something wrong when I had to downgrade. As you suggested I downloaded from the correct location and used the maintained directions. I have it all installed now without any further issues. Consider this thread solved and closed. I had wrongfully assumed that the other documentation was “good”. I reviewed it because I am trying to learn at a high level using some sort of quick start. I’ll start learning from the docs here at a deeper level. Many thanks for setting me on the correct course!


#4

You are welcome.
Nice to here you got it installed smoothely! :slight_smile:
If you do encounter further problems or have questions, you are very welcome to stop by here in the forums again or visit us in the IRC :wink:
Getting started guides and highlevel quickstart documentation is indeed somewhat lacking currently, but getting people up and running faster and more easily is a somewhat big topic just currently, so it would be nice if you would share some of your exerience with us in any case :slight_smile: