Foreman - Puppet Run Option is not applying the puppet classes on nodes

I have configured the puppet run option on using foreman-proxy-puppetrun-provider ssh on Ubuntu 18.04.

When I am applying the classes on nodes using the puppet run options its not getting applied on the puppet nodes. Even I am not able to show any error or warnings in to the logs.

When i tried to check nodes reports form the foreman UI, it’s not generating the reports as well.

Reports are generated after 30 minutes and packages are also applied after 30 mins.

When I run the sudo /opt/puppetlabs/bin/puppet agent -t by login to the nodes clssess are immediately applied on the nodes.

Can you please help me to investigate more on this? If you need any more information on this please let me know.

I will appreciate your help!!


The Infra & CI category is not meant for support questions.

As for the answer:

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.