Katello installation fails due to dependencies issues

I am following instructions on Foreman :: Plugin Manuals
to Install it on the Centos7 with all latest updates

The following repositories have been enabled:

foreman-release-scl-7-2.el7.noarch            Sun 11 Aug 2019 12:09:30 PM UTC
centos-release-scl-rh-2-3.el7.centos.noarch   Sun 11 Aug 2019 12:09:30 PM UTC
foreman-release-1.22.0-1.el7.noarch           Sun 11 Aug 2019 12:09:24 PM UTC
katello-repos-3.12.1-1.el7.noarch             Sun 11 Aug 2019 12:09:22 PM UTC
epel-release-7-11.noarch                      Sun 11 Aug 2019 11:48:51 AM UTC
puppet6-release-6.0.0-5.el7.noarch            Sun 11 Aug 2019 11:48:36 AM UTC

attempts to install katello fail:

Error: Package: tfm-rubygem-katello-3.8.1-1.el7.noarch (katello)
           Requires: tfm-rubygem(bastion) < 7.0.0
Error: Package: tfm-rubygem-katello-3.8.1-1.el7.noarch (katello)
           Requires: tfm-rubygem(bastion) >= 6.1.9
Error: Package: tfm-rubygem-katello-3.8.1-1.el7.noarch (katello)
           Requires: tfm-ror51-rubygem(rails)
Error: Package: tfm-rubygem-anemone-0.7.2-15.el7.noarch (katello)
           Requires: tfm-ror51-rubygem(nokogiri) >= 1.3.0
Error: Package: tfm-rubygem-runcible-2.8.1-1.el7.noarch (katello)
           Requires: tfm-ror51-rubygem(i18n) >= 0.5.0
Error: Package: tfm-rubygem-runcible-2.8.1-1.el7.noarch (katello)
           Requires: tfm-ror51-rubygem(activesupport) >= 3.0.10

What did I miss?
Thanks,
Vadym

Hey Vadym,
Hmm wonder why it is looking for a really old tfm-rubygem-katello-3.8.1-1.el7.noarch, when the current version is 3.12. Do you have a 3.8 repos enabled somehow ?

yum -y localinstall https://fedorapeople.org/groups/katello/releases/yum/3.12/katello/el7/x86_64/katello-repos-latest.rpm
should ve installed 3.12 . If you have the 3.8 repos enabled try disabling them,.

Hi,

If you take a look at the start of the post you will see I have katello-repos-3.12.1-1.el7.noarch is installed.
I will try to check, which rpm requires that old package