Katello not showing all job categories in schedule remote job


Katello doesn’t show the full job category when trying to execute a Schedule Remote Job:

It just shows an empty dropdown list:

But using the Legacy Form it shows all the job categories:

This user has a custom role with the following filters (among others):

If the user has the “administrator” check, it shows the full job categories in the new UI.

Expected outcome:

Show all the job categories in the new Run Job form.

Foreman and Proxy versions:

foreman 3.5.2
foreman-proxy 3.5.2

Foreman and Proxy plugin versions:

katello 4.7.4

Distribution and version:

Rocky Linux 8.7

Other relevant data:

Tested with both lastest Katello and 4.7.0. It worked well with data populated in both cases.
Seems to be related to your local environment.

Is there any solution? We’ve the same problem - Foreman 3.6 no job category in new job invocation form

I am encountering this with Foreman 3.5.3 as well.

New Form for non-admins will not populate the job category or template.
Legacy form working as expected.

For restricted users, I filter job templates on category ( job_category ^ (Packages, Power))

This filter is used for Template invocation, Job template and Job invocation. If I go into Foreman settings and change Remote Execution/Form Job Template, my restricted user can access the job templates that are in the same Job Category as the job in that field, nothing else.

Is there a more appropriate way to implement this? FYI, works for legacy form, not the new form.