Problems creating a repo for an ubuntu 20.04 host

Problem:
I created a repo for ubuntu and get error “Cannot create repository version. Path is duplicated: dists/focal-updates/Release.” when syncing repo
Expected outcome:
populate repo with ubuntu packages
Foreman and Proxy versions:
foreman-2.4.0-1.el7.noarch
foreman-proxy-2.4.0-1.el7.noarch
katello-4.0.0-1.el7.noarch
pulp-client-1.0-1.noarch

Foreman and Proxy plugin versions:

Distribution and version:
CentOS Linux release 7.9.2009
Other relevant data:

Hello All,
So, as the topic says Im having issues trying to create a repo for ubuntu 20.04 hosts (and later 18.04). I have functional CentOS 7 and EPEL repos.

I created the repo like so:

hammer repository create
–product “ubuntu-20.04”
–name “Focal-Updates”
–label “Focal-Updates”
–content-type “deb”
–gpg-key “DEB-GPG-KEY-Ubuntu”
–url “http://de.archive.ubuntu.com/ubuntu
–mirror-on-sync “no”
–deb-architectures “amd64”
–deb-components “main,restricted,universe,multiverse”
–deb-releases “focal-updates” \

I have had to remove the --gpg-key line in all my repo creations and do it in tha gui as hammer says its no longer a valid option as it was when creating repos on Foreman 2.31.and Katello 3.18

The repo looks like this:
image

When I sync the repo I get this:
image

Under Details it says:
image

Hopefully its an easy fix. Coming from Spacewalk, I have to admit Foreman/Katello has not been an easy transition for me. Im much more a sysadmin than a dev ops guy.

Thanks,
Steve

So, I removed all the components from the sync settings and changed the upstream url to http://us.archive.ubuntu.com/ubuntu. Now when attempting to sync the repo , it will run for ~40 minutes and end like this

image

Im hoping someone can throw me a bone so I can get this working while I still have some hair left. Ive searched foreman, atix, ochrhino and redhat and found very little information and less help.

Thanks,
Steve

The initial bug (with the “Cannot create repository version.”) sounds a bit, but not exactly like Issue #8410: syncing deb-repos in pulp 3 fails with "The path for file... overlaps" - Debian Support - Pulp. I will need to check if the error message was changed between pulp versions. If it is the same bug, then that has been fixed in upstream pulp_deb and the fix will be included in the Katello 4.0.1 release.

The other bug you are seeing sounds like Issue #8692: Repository sync will fail if Debian components are defined on the remote - Debian Support - Pulp which was first reported yesterday, and I have not yet had a chance to look into.

I will post again once I know more.

1 Like

Hi,

I’ve followed the orcharino documentation and this Managing deb content in Foreman | Opensource.com, replacing Debian with Ubuntu where needed.

Tell me if you happen to hang on the Foreman IRC sometimes.

1 Like

Adeleglise,
I saw that as well and it looks pretty simple , but it doesnt seem to want to be simple for me so far. What upstream url did you use ?? And no, I dont hang out there. Maybe I should start to sometime.

quba42,
I did actually find that link before posting. I also saw suggestions to remove all components under the sync settings which would sync all the components without explicitely listing them.

I was pretty excited. It looked like the sync was working. But, as stated, after around 40 mins or so , I got the message server disconnected. I tried a half dozen times or so with the same outcome. Ill be waiting eagerly to hear what you find.

Thanks,
Steve

Interesting (sort of), i i dont know enough about how all the components work to know if its related , but I updated to tfm-rubygem-foreman_discovery-17.0.0-1.fm2_4.el7.noarch. Now when I attempt to sync the repo with 0 or 1 components in the repo config , I get
“Cannot create repository version. Path is duplicated: dists/focal-updates/Release”.

All the above steps are attempts to config a working ubuntu repo on my lab instance running Foreman 2.4 and Katello 4.0.

I setup the same repo on my prod box running Foreman 2.3.1 and Katello 3.18 without issue except for having to create /var/lib/pulp/gpg-home manually.