SSH Remote Command

puppet
remoteexecution
proxy

#1

Hi guys i have a problem that is :

“My jobs not running on remote nodes”

I have Foreman and Proxy versions 1.20.2 and my plugin for remote_execution is 1.6.7

If i try run this command from my foreman box shell

sudo -u foreman-proxy ssh -i ~foreman-proxy/.ssh/id_rsa_foreman_proxy root@xxx-domain.com

everything is fine, i can logon.

When i define a job at foreman to run a command, for example “df -h” , i saw in auth.log file on remote node that connection has been accepted with pubkey but my command not run and the job/task is running continous… until i kill the job.

how can i solve this ?


#2

What is the job status? Double check you dynflowd service is running. Also make sure smart_proxy_dynflow_core service is running on your foreman-proxy box.


#3

how can i check if dynflowd service is running ?


#4

i already check and its running

/etc/init.d/dynflowd status

● dynflowd.service - Foreman jobs daemon
Loaded: loaded (/lib/systemd/system/dynflowd.service; enabled; vendor preset: enabled)
Active: active (running) since Thu 2019-05-16 03:26:19 WEST; 7h ago
Docs: https://theforeman.org
Process: 1132 ExecStart=/usr/bin/bundle exec script/dynflowd start (code=exited, status=0/SUCCESS)
Tasks: 11
Memory: 428.5M
CPU: 22.503s
CGroup: /system.slice/dynflowd.service
├─1815 dynflow_executor_monitor
└─1823 dynflow_executor


#5

Can you go to Monitor -> Tasks page and make a screen shot, you should see some job there too, may be good to investigate details. If you see dynflow console button, click on it and send a screen from it too.


#6


#7


#8

Marek check this link Issue with Remote Execution / Pending because of tee not receiving EOF

the problems are the same i think, but i already put the code but the job/task not finish.

i see the job and the script on /var/tmp on node, so the connection is good and the job is send but not finished


#9

its working, after change de code i need to restart services. thanks a lot


#10

Glad you figured out!