Tasks is no longer working after update

I ran “apt update”. The machine told me there are updates for:

  • ruby-foreman-remote-execution:amd64 (3.0.3-1, 3.2.0-1),
  • ruby-foreman-tasks:amd64 (1.1.0-1, 1.1.1-1)

Thus I ran “apt upgrade”. That failed:

Preparing to unpack …/ruby-foreman-tasks_1.1.1-1_all.deb …
Unpacking ruby-foreman-tasks (1.1.1-1) over (1.1.0-1) …
Preparing to unpack …/ruby-foreman-remote-execution_3.2.0-1_all.deb …
Unpacking ruby-foreman-remote-execution (3.2.0-1) over (3.0.3-1) …
Setting up ruby-foreman-tasks (1.1.1-1) …
dpkg: error processing package ruby-foreman-tasks (–configure):
installed ruby-foreman-tasks package post-installation script subprocess returned error exit status 7
dpkg: dependency problems prevent configuration of ruby-foreman-remote-execution:
ruby-foreman-remote-execution depends on ruby-foreman-tasks (>= 0.15.1); however:
Package ruby-foreman-tasks is not configured yet.
dpkg: error processing package ruby-foreman-remote-execution (–configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:

I ran “apt upgrade” again, but that had the same result. Then I ran “dpkg --pending --configure”, which finished successfully. So far so good, I thought; until I clicked in the web interface on Monitor > Tasks and got:

Can’t find entry point ‘foreman-tasks’ in webpack manifest

I tried to disable/enable the tasks plugin, but that did not solve it either.

Expected outcome:
When I click on Monitor > Tasks I expect to see the tasks, not an error.

Foreman and Proxy versions:

Foreman and Proxy plugin versions:
foreman-tasks 1.1.1
foreman_ansible 5.0.1
foreman_discovery 16.0.1
foreman_remote_execution 3.2.0

Distribution and version:
Debian 10.3

Could you have a look into /var/log/foreman-install.log? There, the install/update process of the plugin did hopefully get logged.

Damn, overlooked that point… Will look into it.

This is the complete log. I will also have a look into it myself in the meantime.foreman-install.log (168.8 KB)

I just discovered, that I cannot delete hosts. Whenever I click on that red “delete” button it tells me to “wait while my request is processed” and then I am back where I started: The host is still there. I am not entirely sure if it is related to this topic, but I know deleting hosts worked before.

I can’t replicate the problem with a new install, so maybe just a systemctl restart apache2 is missing to reload all the plugins. However, with Remote Execution installed, you’ll run into Bug #29793: 3.2.0 is not compatible with Foreman 2.0 - Foreman Remote Execution - Foreman (which I just discovered) then.

I had the same problem in one environment and after updating to 2.0 I ended with Bug #29264: Host task show nothing - Foreman Remote Execution - Foreman, perhaps this is related and the debug information there are helpful for analyzing.

I do not know how or why, but when I click on Monitor > Tasks now, I get the page showing the tasks. So, the web interface seems to work.
I do not know if the issue, that I cannot delete hosts, is related to this, but that one still persists.

The cannot-delete-hosts-problem has been solved by the update of ruby-smart-proxy-remote-execution-ssh to version 0.3.0. Since Tasks seem to work again, I will mark this thread as solved, thank you all for your help and effort!