Centos mirror with kickstart tree to use it as installation media?

katello

#1

Hi all,

I would like to use my katello synced yum repos as installation media for CentOS hosts but when I try to add a new host the option “synced content” in OS >> media selection is always greyed out and I cannot select it. I have read that my mirror should include a “kickstart tree” so I can use it to install the OS but I am not sure what this means.

Can anyone point me to a centos yum repo including a kickstart tree which can be used to install the hosts or is this something that I should create outside katello?

I know I can create an “installation media” pointing to the url of my local yum repo but I think the recommended option is to use “synced content” isn’t it?

I am using foreman 1.6 and katello 3.5.

Thanks in advance for any help.
Pablo.


Katello best practices?
#2

Afaik Katello plugs into the helpers for installation media in templates so
it should just work™,
without the need for selecting inst. media. You just need to have content
source proxy selected

– Ivan

pá 12. 1. 2018 v 13:26 odesílatel Pablo Escobar <
noreply@community.theforeman.org> napsal:


#3

Hi Ivan,

Thanks for your help but I think I am missing some important detail.

I have create a Content view named “Centos_7.4” which includes all these repos:
http://mirror.switch.ch/ftp/mirror/centos/7.4.1708/os/x86_64/
http://mirror.switch.ch/ftp/mirror/centos/7.4.1708/extras/x86_64/
http://mirror.switch.ch/ftp/mirror/centos/7.4.1708/updates/x86_64/

Then I have promoted the content view to “lifecycle environment >> library >> prod” and created a activation key with name “Centos_7.4” associated to environment “prod” and content view “Centos_7.4”

Now if I go to hosts >> all hosts >> create host and I select:

Lifecycle Environment > prod
content view > Centos_7.4

in the “operating system tab” I select
architecture: x86_64
OS: CentOS 7.4.1708

but the “Synced Content” check is always greyed out and I cannot select it. I cannot select nothing in the “media” section neither. If I try to create the host it fails and I get a red warning next to the “media” section which says “cant’ be blank”

I have tried to review the options in hosts >> operating systems but I cannot find how to associate the operating system “CentOS 7.4.1708” with my content view “Centos_7.4”

I am out of ideas…maybe I have to assign the activation key to this host somehow?

Thanks in advance for any help or suggestion.


#4

Pablo_Escobar https://community.theforeman.org/u/pablo_escobar
January 12

Hi Ivan,

Thanks for your help but I think I am missing some important detail.

I have create a Content view named “Centos_7.4” which includes all these
repos:
http://mirror.switch.ch/ftp/mirror/centos/7.4.1708/os/x86_64/
http://mirror.switch.ch/ftp/mirror/centos/7.4.1708/extras/x86_64/
http://mirror.switch.ch/ftp/mirror/centos/7.4.1708/updates/x86_64/

Then I have promoted the content view to “lifecycle environment >> library

prod” and created a activation key with name “Centos_7.4” associated to
environment “prod” and content view “Centos_7.4”

Now if I go to hosts >> all hosts >> create host and I select:

Lifecycle Environment > prod
content view > Centos_7.4

in the “operating system tab” I select
architecture: x86_64
OS: CentOS 7.4.1708

Have you selected “content source” on the first tab of the new host form?

but the “Synced Content” check is always greyed out and I cannot select it.


#5

Hi Ivan,

I don’t know what I was doing wrong but after starting from scratch (I have deleted all content views, products, activation keys and operating systems) I have created a new content view for Centos7 a then a new operating system “CentOS 7” has been automatically created and when I select this operating system I can select “synced content” as installation source.

Thanks for your help!