Warning: Anaconda failed to fetch kickstart issue

I tried to deploy a CentOS 7.5 host via PXE. My Foreman version 1.16.2.
I keep getting the warning: anaconda failed to fetch kickstart from[…] error message. I tried looking in this forum as others had this issues before me but nothing worked.
Hope someone can help me further

the host you’re trying to provision can’t resolve the janis-foreman.local hostname to its IP address. Are you sure your DNS is configured properly?

Pretty sure I did that and that the host could even ping the server hostname in the dracut emergency shell. Will look into that after the weekend and give feedback of course, thank you for the tip. Couldn`t it be something else?

alright it was a dns/dhcp related issue, nothing related to foremans default configs. thanks for your help! unattended installations are working now!

Glad to hear that, it could in theory be caused by other things, but usually it is the dns :slight_smile:

1 Like

Hi all, just wanted to include some weirdness that I’ve just experienced which manifested as the exact same problem but wasn’t DNS/DHCP related…

For me the initial discovery image kickstarted just fine however, when it went to kickstart from the default kickstart template I got the SAME ERROR AS IN THIS ORIGINAL POST.

When looking at this (look at the ks= part) via a browser:

[root@foreman-test pxelinux.cfg]# cat 01-00-50-56-0f-03-01
# This file was deployed via 'Kickstart default PXELinux_VidEng' template

MENU TITLE Booting into OS installer (ESC to stop)
ONTIMEOUT installer

LABEL installer
  MENU LABEL Kickstart default PXELinux_VidEng
  KERNEL boot/centos7-2-1511-Nf_ahzJutO-vmlinuz
  APPEND initrd=boot/centos7-2-1511-Nf_ahzJutO-initrd.img ks=http://foreman-test.velab.cox.net/unattended/provision?token=db0cac76-0a6b-4846-92b8-b4e31808e355  network ksdevice=bootif ks.device=bootif BOOTIF=00-00-50-56-0f-03-01 kssendmac ks.sendmac inst.ks.sendmac ip= nameserver=

I noticed the status of the below when examing the link directly via web browser:
There was an error rendering the Kickstart default_VidEng template: The specified snippet ‘setHostName’ does not exist, or is not a snippet.

I had been experimenting w/a snipped named “setHostName” and had thought I had commented it out properly in my kickstart template as:

poundsign Set hostname
poundsign <%= snippet ‘setHostName’ %>

Apparantly that wasn’t sufficient to comment it out as the template was still trying to render it…

Once I completely deleted the snippet line life was good again…

I’m not yet a foreman/katello expert so maybe this is a “cornbread newbie” mistake but hopefully this will help y’all… :wink: