Request for Pulpcore 3.18 builds

I’d like to request Pulpcore 3.18 builds from the delivery team. Here are the packages, which are all currently the latest versions:

pulpcore 3.18.1
pulp-rpm 3.17.4
pulp-container 2.10.1
pulp-file 1.10.2
pulp-ansible 0.12.0
pulp-ostree 2.0.0a5
pulp-python 3.6.0
pulp-deb 2.17.0
pulp-certguard 1.5.2

Katello is planning to first integrate with pulpcore 3.17, so having these builds within the next 3 weeks or so should be just fine.


It sounds like Pulpcore 3.19 is coming out next week, so skipping 3.18 for that might make more sense.

@pcreech maybe we should skip 3.18

I think this would be more dictated by the needs of other consumers of our pulpcore bits (automation hub), but if they’re fine, i’m fine.

I’ve confirmed automation hub needs 3.18 bits and will not have time to rebase on 3.19

Sounds like we’ll stick to the original plan then.

In a meeting with Pulp today, they mentioned that it would be nice if Katello 4.5 could use Pulpcore 3.19. Given that 4.5 branching is on May 10th and GA is June 9th, would it be possible to build Pulpcore 3.19 in that time frame? Katello would need 2 weeks at worst and a few days at best to prep the code base.

If building 3.18 (which I think is still in progress?) takes up all that time, then we’ll just upgrade to 3.18. If Pulpcore 3.19 can be built in the remaining time, we’ll skip to that.

I’m finishing the bits for 3.18 this week, we can start the 3.19 work in the next week.

Okay, thanks @Odilhao. I’ll try to stay up to date with the packaging to make a better decision about choosing 3.18 or 3.19 for Katello 4.5.

Does Katello 4.5 still support EL7? Because pulpcore 3.18+ currently doesn’t.

We’ll need to discuss dropping EL7 support for Katello 4.5 at the next release meeting. It sounds like it was already on its way out, so we can plan out next steps for making it official.

We planned to release Foreman 3.3 w/o EL7, but than decided to pull back and do that in 3.4:

By that logic, Katello 4.5 would also have EL7 support, but not w/o Pulpcore…

Pulpcore 3.18 is expected to be in 4.5.0, so it seems we may need to drop support EL7 after all. Hearing that Pulpcore 3.18 doesn’t work on EL7 was a bit of a surprise.

It’s not like it doesn’t work. It’s just not built for EL7.

That makes sense. How solid of a decision is it to not build 3.18 for EL7?

That’s up for @pcreech and @Odilhao to say.

Pulpcore 3.18 is being built on Python 3.9, to add support for EL7 would be necessary to create a new SCL for python 3.9.

Tagging @pcreech for this

From today’s release meeting it sounds like we’ll aim for reintroducing EL7 to the Pulpcore 3.18 build. Due to the increased workload, we’ll stick to 3.18 for Katello 4.5 rather than do another packaging job for Pulpcore 3.19 right away.

Just adding the agreed to information to this thread:

We are adding el7 back in for Pulp 3.18. Due to the complexities of introducing a ‘Python 3.9’ SCL, we will stay on python 3.8 for el7. This was the main factor we decided not to build for el7, due to expectations that we will be dropping el7 support in foreman/katello.

This will cause a divergence of interpreter stack, and if there are any ‘works on el8+, fails on el7’ issues, this could be a potential reason.

Once el7 is added back to 3.18, we can re-evaluate expectations around 3.19

1 Like

It’s finally out.

Right now Pulpcore 3.18 is built on python38 for EL7, and on python39 for EL8 and EL9.

1 Like